1. I was trying to download combat tracker.zip file and it just gives gibberish. Other chapters with the same problem are :- 10, 14, 15, 17 (File - SABTest.zip ). I have not checked any others.

    Are you typing in the URL or going off the main chapter link page? Some of the files are still messed, but I'll get them adjusted. But it will help me to know how you're trying to get there.

    All the ones I've seen are fixed.. thanks for the report!

    I was following the links on each page to drill down to the files. I have just downloaded the file 'PlayerFramePlus' and when I tried to open it winzip reported the following:- End-of-central-directory signature not found. Either this file is not a Zip file, or it constitutes one disk of a multi-part Zip file. The HelloWorld zip file also give same error. Tried this at 23:13 the chapter 12 file still gives gibberish.

    I fixed the issue with Chapter 12. But I cannot reproduce the errors you are talking about. When I browse to http://wowprogramming.com/chapters/16 and click on the PlayerFramePlus link it brings me to http://wowprogramming.com/chapters/16/PlayerFramePlus. Clicking the "Download this file" link gets me PlayerFramePlus.zip, which I can then unzip to get the contents.

    The same for HelloWorld. Are you sure you're not opening a cached download or something?

    Still cant download from this site, I've tried downloading files from other sites and they work ok. Seems I only get 3Kb of the file anytime I try. I have no idea what could be causing this, any suggestions?

    No, I really do not. To be clear, you are clicking the link and then going to the "Download this file" link? Can you email me one of the 3k files you have downloaded? You can address it to jnwhiteh at this domain name.

    Yes I am following the links on each page to get to the zip file. I'll send you the comabt tracker file i just downloaded.