Feedback and support for wowprogramming.com.

Login to create a new discussion topic

Subject Last Post
Something i'm seeing that's happening a lot recently is that Blizzard seems to put a lot of functions under a C_ table. such as C_Scenario.IsInScenario(), C_Scenario.IsChallengeMode() and so on. At first i thought its because they were more specifi...
2014/06/21 18:35:14 by Lombra
Ui.xsd not up to date posted by Xers
Hi James, it would be awesome if you could update the Ui.xsd :-D (http://wowprogramming.com/FrameXML/UI.xsd) love your work thanks in advance Xers
2014/01/17 20:26:10 by jnwhiteh
Missing Event and Functions posted by ludovicusmaior
Would you mind terribly adding the following so I can fill them in? - QUEST _ CHOICE _ UPDATE - GetQuestChoiceInfo() - GetQuestChoiceOptionInfo() - GetQuestChoiceRewardInfo() - GetQuestChoiceRewardItem() - GetQuestChoiceRewardCurrency() - Ge...
2014/01/02 20:44:56 by jnwhiteh
Chat Channel Option posted by colonyl3
Hello, im still new to lua, and im kinda stumped, ive been picking apart at a abandoned addon, whos author hasn't logged on curse forged in 2 years. the addon still words and ive been about to update that data and make some minor tweaks. But i want t...
2013/10/09 05:09:08 by jnwhiteh
if statement posted by m4dc0w344
what is wrong with this? ------------------ __hello first I want to say that I'm new on this forum so hey ! :) second could someone please tell me what am I doing wrong here? local frame = CreateFrame("FRAME", "FooAddonFrame"); frame:Regis...
2013/09/10 00:54:06 by hehling01
I've decided to help with some of the undocumented API functions and it occurred to me to ask - does this info exist somewhere, in the game or elsewhere, or does it need to be found out by trial and error? And what about data types, many of which s...
2013/01/16 10:22:39 by malsomnus
Erroneous Webpage posted by Drae
Looking up the use of UnitBuff and found a page that should not be there: http://wowprogramming.com/docs/api/UnitBuff)
2012/09/06 07:25:23 by stevenlaw
help [addon] posted by deltoide
friends, I have this addon that whenever I go into combat, the windows of the minimap and chat are invisible. local HiC = CreateFrame("Frame", "HiC", UIParent) function HiC.OnEvent(self, event) if event == "PLAYER_REGEN_DISABLED...
2012/07/15 18:20:50 by jnwhiteh
Art Browser version posted by p3lim
Could you add something like a header to the art browser that tells which game version it is taken from? Never know if its outdated or not.
2012/03/15 09:48:58 by jnwhiteh
I'm currently working on a 3d model of the Argent Crusade Banner & post that holds it, how would I go about getting the actual banner texture ? Any help on this would be greatly appreciated.
2011/11/21 13:30:41 by jnwhiteh
Posting reminder per request: If you try to post something when not logged in, this error shows up (or at least, it did the once): http://wowi.pastey.net/86901 Feedback: After hitting the save button, it shows you what you've posted, which is good,...
2011/07/27 04:59:05 by romancefer
How can i get rid of the javascript ondblclick that is on the code spinets? It constantly gets me when I try and copy a word/line i try double clicking and get the entire code set in my clipboard like on this page that I have been using a lot for ...
2011/07/16 09:37:19 by jimmy1988
BLP2PNG Conversion Failure posted by meorawr
I noticed that the (http://wowprogramming.com/utils/blp2png "BLP to PNG") conversion script fails on BLP images that have their compression mode flag set to 3, which is true for two or three files in the extracted art files you can obtain from the Wo...
2011/06/25 20:16:38 by jnwhiteh
Wrong forum. Sorry. This can be deleted.
2011/05/26 03:30:58 by grimskin
Error on cancel posted by Cayenne
If I cancel a post that I am creating or editing, I get a "does not support action .cancel" error message. This doesn't create any actual problems but I though I'd let you know.
2011/05/03 21:51:24 by jnwhiteh
CLEU and your RSS feed posted by Myrroddin
Having mentioned an Event change before, you informed me that your RSS feed keeps you updated on changes. In any case, I am still baffled by what to put where on the edit page in order to update. Would it be possible to put a quick how-to into the pa...
2011/05/02 08:17:34 by jnwhiteh
Snippets posted by l3gsh0t
When I try to post a snippet, the formatting is changed on my code. It is removing new line calls (CR, NL). This is squishing the code together in a very hard to read way, or possibly in a way that wouldn't work in a programming environment. It also ...
2011/02/08 18:24:08 by jnwhiteh
Hi Mr. Whitehead, is there a way to link straight to a line number in the FrameXML Browser? Like, adding a **#line** after the file? > http://wowprogramming.com/utils/xmlbrowser/live/AddOns/Blizzard_GlyphUI/Blizzard_GlyphUI.lua#550
2011/02/03 19:37:16 by Ketho
But I couldn't see how to edit the API listings to mark it as such.
2010/12/15 10:56:33 by fljaweiu
Change API Categories posted by melzedan
Is there a way to alter the API categories? I tried to mark some functions for archaeology but the label turned into "_(API_CAT_ARCHAEOLOGY)"...
2010/12/09 11:35:42 by jnwhiteh
[Event update] posted by Myrroddin
Mr Whitehead, I edited `GUILD_RANKS_UPDATE()` in the reference section, after a friendly officer promoted and demoted me a few times while I used eventtrace. Not sure if my edit is how you like the page, but here is the syntax: `GUILD_RANKS_UPD...
2010/12/06 11:46:07 by jnwhiteh
My connection is slow this morning (due to downloading a WoW patch) and I entered my password on the account activation page and submitted before the captcha had loaded. I got a sputnik error about an assertion failing. I think it's great that yo...
2010/11/16 18:29:27 by jnwhiteh
I'm only in the first chapter and I figured I'd visit the website and have a look at the first addon to see how it was written compared to mine, and I can't find it. The book says to go to http://wowprogramming.com/chapters/01 - which doesn't work...
2010/11/02 08:03:53 by ojausghe
Art and Frames Browsing Tool posted by marshbum
Will there be an update coming for the art and frames browsing tool on your website to account for the patch 4.0.1 updates? I loaded the new versions on my PC and see a bunch new stuff. Thanks in advance for all the work you are doing to help us.
2010/10/19 12:28:49 by jnwhiteh
Where do you change the password for you account?
2010/10/17 11:26:53 by jnwhiteh
I think the format is confusing:   http://www.wowprogramming.com/docs/api/IsAltKeyDown What does it return? Does it return -1 or is the "-" just a sperator so it really returns 1? (Or does it return something else entirely)  
2010/10/13 23:55:27 by magicsimon
Sputnik not working ? posted by Philburt
Tried to access the developemt forum but all i got was an error message telling me : Sputnik ran but failed due to an unexpected error.Error details: :58: .../sputnik-forums/cvs-1/lua/sputnik/actions/forums.lua:107: attempt to compare string with nil...
2010/10/12 08:45:25 by uywerop
At the top of the page, the parts that says "You are logged in as 'username' (Logout)" and the searchbox are underneath the image that says "World of Warcraft Programming". You can't click anything in the lower layers, only the embedded link to go b...
2010/10/07 03:10:01 by sdghyulmr
Jim, For some reason, a thread that I started is broken. You can find it here: http://wowprogramming.com/forums/development/300 I wanted to continue this discussion (I created the code you suggested and it works marvelously! And I had a follo...
2010/06/09 21:15:05 by jnwhiteh
mac lua interpreter posted by aradel
so I have an "older" mac with v10.4.11 and the interpreter under tools won't work it says I need the new fancy version of the OS is it possible to get a version that works for all OS versions?
2009/10/12 09:53:08 by jnwhiteh
I have purchased World of Warcraft Programming and when I lookup the event: COMBAT_LOG_EVENT_UNFILTERED on the website I'm referred to this chapter but can't find it. Any suggestions on where to find a detailed description of information supplied i...
2009/08/27 14:31:26 by jnwhiteh
Someone might want to confirm this, but I thought it could be noted on the CalendarGetNumDayEvents page that it will count the Blizzard created events in month offset 1 out to the second Tuesday of that month. I haven't tested -1, but I have had a se...
2009/07/07 16:27:47 by Quasi
Chapter 12 download fail posted by Barinor
I was trying to download combat tracker.zip file and it just gives gibberish. Other chapters with the same problem are :- 10, 14, 15, 17 (File - SABTest.zip ). I have not checked any others.
2009/06/15 10:57:00 by Barinor
As of 22:40 8th June the chapter 12 link still gives a busted link. See my previous post on chapter 12.
2009/06/09 12:06:07 by jnwhiteh
Chapter 13 download fail posted by Talanthas
I was trying to download the TargetText addon but it gives me this error: Requested action does not match file content: nil Followed by a whole ton of jumbled letters. Several other downloads appear to not be working as well.
2009/06/02 20:08:19 by jnwhiteh
Macintosh posted by trav
Lua-WoW (PC Zip, Mac DMG) - Modified Lua distribution that includes changes to more closely match the WoW environment. See the readme files for more details. Whoops, page utils/mac/lua-wow does not support action .dmg. got this when clicking on t...
2009/05/25 22:28:24 by jnwhiteh
Firefox, right click Save Image As... when right-clicking the image displayed on the BLP2PNG page forces a file name extension of, of all things, .com.  The default suggested name was actually www.wowprogramming.com with a file type of "PNG".&nb...
2009/04/14 08:17:07 by Aesir
Spent days waiting for the email to confirm account email never came. 48 hours later had to sign up for a new email address with gmail just to join the site, please fix this issue and also add a password retrival. I do not want another email just to ...
2009/03/24 18:36:50 by jnwhiteh
I tried going into the development forum to catch up, and ask a question, but I get this: Sputnik ran but failed due to an unexpected error. Error details: :58: .../sputnik-forums/cvs-1/lua/sputnik/actions/forums.lua:107: attempt to compare s...
2009/01/04 15:57:48 by jnwhiteh
How do I get topic notification for my posts or any posts that I have replied to? How do I locate posts I have made without using Ctrl+F on every catorgy page?
2008/12/17 08:53:08 by jnwhiteh
Searhing the forums? posted by StuzUK
Where is the search button or is it me?
2008/12/17 08:52:06 by jnwhiteh
Lua interpreter download posted by gloreynn
On page 6, chapter 1, of the book, the website "http://wowprogramming.com/downloads/lua/windows" is given to download the Lua interpreter.  When the link is clicked on to download the file, it redirects to a page with the error message: Whoops...
2008/11/04 08:49:25 by morlando
Forums display posted by Drayeah
In the forums section I see a bunch of HTML tags (like <p> etc...) being displayed. This makes the text very bad readable. Also The book support section does not seem to sort the posts properly. I made a post and I could not see it and posted i...
2008/08/20 14:10:28 by jnwhiteh
When clicking on development link get this error: Sputnik ran but failed due to an unexpected error. and no content is displayed  
2008/07/22 20:47:20 by jnwhiteh
Just a note that the WebLua does not provide a stack traceback as described at the top of page 37.  I realize that this is not an truely an error, but it's something that you may want to mention. --Frankaladin
2008/06/15 08:31:18 by jnwhiteh
WoWLua Addon posted in Website posted by Dotdotgoose
On page five, chapter one of the Programming for World of Warcraft book it says navigate to: http://wowprogramming.com/addons/weblua and click the download link to get the zip file. I have a question, where is the download link?
2008/06/14 15:31:36 by jnwhiteh
Just got the book and I'm typing in every example as I go. I just got to page 17 and I'm down to the "Assigning Variables" section. In the book it looks like this... > foo = 14 > print (foo) 14 > foo = "Hello!" > print (foo) Hello! But when I typ...
2008/06/14 15:25:34 by jnwhiteh
Rarr! posted in Website posted by Cairenn
Looks great guys, congrats! I know the number of hours of work that have gone into this.
2008/05/17 23:34:45 by jnwhiteh
I'm really not trying to be a pita, sorry. =/ From Shadowed's post: &llt;p&lgt;Preview for editing API references isn't working, all it does is show a link with "Change", and two buttons "Save" and "Cancel" but no actual preview.&llt;...
2008/05/17 23:34:44 by Cairenn
Why can't I edit my postings? When I click on the edit link, I get this message: Sorry, that action is not allowed ??????????????? as we say in the land of great confusion trav
2008/05/17 23:34:44 by jnwhiteh
Part of the example code at: http://www.wowprogramming.com/docs/api/GetItemFamily contains: -- If the item is a container, then the itemFamily should be 0 local itemType = select(6, GetItemInfo(item)) if itemType == "Container" or itemType ...
2008/05/17 23:34:44 by jnwhiteh
Search box Categories or some organizational hierarchy for events? Not really sure what works best here, but there's gotta be some way to pull it up from just a flat list. Widgets are easy since there is clear inheritence, API reference has categori...
2008/05/17 23:34:43 by morlando
XSSFilter could not parse (X)HTML
2008/05/17 23:34:43 by jnwhiteh
I am getting this when I try running it: /Applications/Lua-WoW.app/Contents/MacOS/launch: line 5: /Applications/Lua-WoW.app/Contents/MacOS/lua: cannot execute binary file /Applications/Lua-WoW.app/Contents/MacOS/launch: line 5: /Applications/Lua-WoW....
2008/05/17 23:34:43 by jnwhiteh
It seems to give an error "Sorry that action is not allowed" when clicked. The other utilities appear to be fine.
2008/05/17 23:34:43 by morlando
XSSFilter could not parse (X)HTML
2008/05/17 23:34:42 by jnwhiteh
Need a password reset option... Edit: posting this for Guillotine :P
2008/05/17 23:34:42 by Guillotine
Ability to change the size of the weblua window DONE Ability to specify float for images Won't do Rather than concatenating the short and long descriptions, the long description should be moved underneath the returns section DONE Sor...
2008/05/17 23:34:42 by morlando