1. Hi,

    i'm trying to detect (via events) when a party member starts to get on his mount.

    There are "UNIT_SPELLCAST_SUCCEEDED" and "UNIT_SPELLCAST_INTERRUPTED" events sent when the mounting was successfull or interrupted. But there is no "UNIT_SPELLCAST_START" event when the 3 second process of mounting is initiated.

    Maybe i'm just not aware of the "right" event to listen to? Any advice would be appreciated.

    regards

    Max

    Hi,

    i'm trying to detect (via events) when a party member starts to get on his mount.

    There are "UNIT_SPELLCAST_SUCCEEDED" and "UNIT_SPELLCAST_INTERRUPTED" events sent when the mounting was successfull or interrupted. But there is no "UNIT_SPELLCAST_START" event when the 3 second process of mounting is initiated.

    Maybe i'm just not aware of the "right" event to listen to? Any advice would be appreciated.

    regards

    Max

    Using /dtevents in DevTools, I can see the following events fire:

    UNIT_SPELLCAST_START

    UNIT_SPELLCAST_SUCCEEDED

    UNIT_SPELLCAST_STOP

    Are you seeing something different? 

    Thank you for bringing this "DevTool" Addon to my attention, i wasn't aware of it before. The event trace really makes things easier.

    You are right. For yourself you also receive the Spell_Start event, but not for party members. They only send COMPANION_UPDATE followed by UNIT_SPELLCAST_SUCCEEDED, but both only after mounting is finished. Initiation of mounting is not accompanied by any party-wide event.

    From the event trace i now know that there are no other events i can listen to, which kinda sucks, but at least now i know and can move on.

    Thanks again for your input!

    regards

    Max