1. The script with the issue: http://code.google.com/p/wow-dameter/source/browse/Dameter.lua

    On my main character - which I was using to learn to develop addons - the print function stopped working. It use to work, but now... Other addons still working normally. No error - I use swatter to debug. No nothing. Messages simply get not printed. On the other hand, if I login with my other character - same realm - it works perfectly.

    I tried cleaning WOW preferences - deleting WTF and other directories - but nothing changed.

    Any clues ?

    No idea, I'd try to do some basic debugging. Is the addon even being loaded?

    Yes, it is.

    I double checked everything. And make note that if I login with other characters (they're on same realm) it works perfectly.

    I also tried /run print("Test") to make sure print is not overridden, and disabling every other addon too.

    Then it sounds like the logic of the addon for that character is somehow changing. I have absolutely no idea why that would happen.. =/

    Man, some guy on battle.net forums solved the case: http://us.battle.net/wow/en/forum/topic/4254519495

    Thank you, anyway, for your time! ;)