1. Ok I must be an idiot, but I really cannot see why I can't move this frame:

    <Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/

    ../FrameXML/UI.xsd">



        <Frame name="CStatsTitle" parent="UIParent" enableMouse="true" movable="true" frameStrata="LOW">

            <Size x="100" y="32"/>

            <Anchors>

                <Anchor point="CENTER" relativePoint="CENTER" relativeTo="UIParent"/>

            </Anchors>

            <Backdrop bgFile="Interface\DialogFrame\UI-DialogBox-Background" tile="true"/>

            <Layers>

                <Layer level="OVERLAY">

                    <FontString setAllPoints="true" justifyH="CENTER" inherits="GameFontNormalSmall" text="CStats"/>

                </Layer>

            </Layers>

            <Scripts>

                <OnDragStart>

                    self:StartMoving()

                </OnDragStart>

                <OnDragStop>

                    self:StopMovingOrSizing()

                </OnDragStop>

            </Scripts>

        </Frame>



    </Ui>

    Could anyone help me please?

    Ok I must be an idiot, but I really cannot see why I can't move this frame:

    <Ui xmlns="http://www.blizzard.com/wow/ui/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.blizzard.com/wow/ui/

    ../FrameXML/UI.xsd">



        <Frame name="CStatsTitle" parent="UIParent" enableMouse="true" movable="true" frameStrata="LOW">

            <Size x="100" y="32"/>

            <Anchors>

                <Anchor point="CENTER" relativePoint="CENTER" relativeTo="UIParent"/>

            </Anchors>

            <Backdrop bgFile="Interface\DialogFrame\UI-DialogBox-Background" tile="true"/>

            <Layers>

                <Layer level="OVERLAY">

                    <FontString setAllPoints="true" justifyH="CENTER" inherits="GameFontNormalSmall" text="CStats"/>

                </Layer>

            </Layers>

            <Scripts>

                <OnDragStart>

                    self:StartMoving()

                </OnDragStart>

                <OnDragStop>

                    self:StopMovingOrSizing()

                </OnDragStop>

            </Scripts>

        </Frame>



    </Ui>

    Could anyone help me please?

    You forgot to self:RegisterForDrag("LeftButton") in the OnLoad handler.

    Told you I was a dimwit :P

    Thanks a lot! :)