1. Hello everyone, I've been kind of out of the wow scene for awhile and alot changed since, including addOn dev. Even tho I have read threads in the UI/Mac forums and here I still can not figure out why it's not working anymore. Could someone give me a clue why?

    Lua file -> http://pastey.net/143350-16d8

    XML code (points of interest)

    Scripts

    OnLoad functionX_onLoad(); /OnLoad

    OnEvent functionX_onEvent(); /OnEvent

    /Scipts

    What you're posting has nothing to do with WoW 4.0... in fact its bare basic addon development. I suggest you pick up my book or read some tutorials if you want more information.

    Basically, you're indexing 'self', which doesn't exist. Either there's more code you're not showing or this is some frankencode that definitely doesn't do what you want it to do.

     local frame = CreateFrame("Frame")
     frame:RegisterEvent("PLAYER_ENTERING_WORLD")
     frame:SetScript("OnEvent", function(self, event, ...)
       if event == "PLAYER_ENTERING_WORLD" then
         DEFAULT_CHAT_FRAME:AddMessage("Great Sucess")
       end
     end)
    

    That in an addon will do what you want it to do, but you can't run it after the game has started, since the PLAYER_ENTERING_WORLD event will have already fired.

    Already have your book =P and you're right I got it working.

    Just my recent journey into the world of C that messed with my LUA abilities obvious pebcak* problem =P

    (*problem exists between chair and keyboard)

    No worries =)