1. Hi everyone!

    I know about the fact that GetItemInfo() only returns something when the item data is available in cache. I think I still haven't completely understood everything about it and maybe that is the reason for my problem, but still I have a situation that I don't understand:

    I am looping through all the tradeskills in a (my Blacksmith) tradeskill window and get the itemLinks of the non-header items via GetTradeSkillItemLink(). I pass the result to GetItemInfo(). Whenever the function returns nil, I call GameTooltip:SetHyperlink(link). My expectation would be that the item should be available in the local cache a while after GameTooltip:SetHyperlink() has been called. This seems to work most of the time.

    The problem I am having is that even having seen the item tooltips (and therefore I expect that the items are available in the cache), the function GetItemInfo() always returns nil for socket bracer and socket gloves. Does anyone have an idea?

    Thanks, Christian

    What happens if you query by itemId rather than by the full hyperlink? Does it always happen on certain items, if so, what are they?

    As I wrote, it happens always for "socket bracer" and "socket gloves".

    I will try it with the id to see if it works at all, but in my code I do not have the ID but only the link. I could extract it from the link, okay... I will try and see what happens.

    -->> Checked it with the ID and it still does not work!

    I'm not quite sure what to tell you then.. I don't know why it doesn't seem to be working for you. I'll try to figure something out, but I don't know how much I'll be able to do.