1. I'm following the CombatTracker example.

    When I start wow, I get the following error message: to call global 'CombatTracker_OnLoad'(a nil value)

    This happens when I left click the frame as well:

     Message: [string "CombatTrackerFrame:OnClick"]:1: attempt to call global 'CombatTracker_ReportDPS' (a nil value)
     Time: 08/23/09 16:38:52
     Count: 1
     Stack: [string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:18: in function <[string "Interface\FrameXML\BasicControls.xml:<Scrip..."]:4>
     [C]: in function `CombatTracker_ReportDPS'
     [string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>
    
     Locals: self = CombatTrackerFrame {
      0 = <userdata>
     }
     button = "LeftButton"
     down = false
     (*temporary) = nil
     (*temporary) = "attempt to call global 'CombatTracker_ReportDPS' (a nil value)"
    

    Any idea why I might be getting these messages?

    Thanks

    This means that your XML file is loading properly but either you dont' have those functions defined in the Lua file, or something else is wrong. Could you post the current versions of your files on http://pastey.net.

    Alternatively you can compare your versions to those available for download at http://wowprogramming.com/chapters/12.

    I attempted to download the zip file for Chapter 12; however, each time i have tried to open the file, I receive an error stating that the file is corrupt. I've tried re-downloading it several times with the same result.

    So here are the two pastey.net links to the xml and the lua code that I have typed up. I've tried to find the error, without any luck.

    http://pastey.net/124426 http://pastey.net/124425

    Thanks

    Try download 7zip and unzipping the file using that software. Are you using WinRar by any chance?

    I was using Winzip.

    I installed 7Zip, and I get an error message with that as well, stating that it is an invalid archive.

    You use a capital 'E' on the "End" right before the start of CombatTracker_ReportDPS. This is causing the Lua file to not load (and should be showing an error to that effect). As a result, the function is not created when you go to click on the button.

    Thank you for your help.

    The "E" was one problem, which allowed me to find another one. But it seems to be working now.

    Thank you for the effort!

    Jody