1. I think I should have picked up a book on XML programming before getting this but a couple people said this book was the way to go regardless of skill level at programming. This is my question. I have done the gradiant and the Icon test from chapter 10 but when I load into wow I don't see anything. I have verified that the version number is correct and that the code is just like it is in the book. I actually even downloaded the example files just to make sure and still did not see the frames loaded. I do have the Blizzard Addon Kit extrated in the main directory of World of Warcraft that has both the code and the art. Is it not displaying because this bit of code doesn't have any behaviors set or am I missing something?

    Thanks! LOVE the book!

    I think I should have picked up a book on XML programming before getting this but a couple people said this book was the way to go regardless of skill level at programming. This is my question. I have done the gradiant and the Icon test from chapter 10 but when I load into wow I don't see anything. I have verified that the version number is correct and that the code is just like it is in the book. I actually even downloaded the example files just to make sure and still did not see the frames loaded. I do have the Blizzard Addon Kit extrated in the main directory of World of Warcraft that has both the code and the art. Is it not displaying because this bit of code doesn't have any behaviors set or am I missing something?

    Thanks! LOVE the book!

    Does the addon show up in the Addons list at the character selection screen?

    It does show. I went to the tutorials suppled by blizzard as well and copy and pasted it in, and at first it didn't show. When I moved their example addon folder over it did work. I rewrote the program but this time I didn't use dreamweaver for the XML and it worked for me that time too. But when I tried to do the same with the code from the book it still didn't show the frame. It may have been a typo though. I am pretty sure my problem was dreamweaver especially since it is an educational version.

    Dreamweaver may be doing something weird to the XML that breaks the code that's being written..  Please note that you don't really need to use XML in any way if you don't want to, as the same things can be acomplished via straight Lua code.



    When in doubt you should always ensure you are using a plain-text text editor that doesn't try to do anything else for you.  That way you've got one tool out of the equation that could be your ptential problem.