1. so I am a complete newcomer to programming. I tried learning python via a wiki but got bored as i was not doing anything interactive. so I saw this book and thought I would give it a go. so Im already stuck in the first chapter (like I said Im a noob and there may be many questions from me depending on how long I last before being demoralized). at the heythere addon part i did everything the book says..or so i thought. but i cant see the addon in my addon list. i did save it where all my other addons are and they show up? if it helps im running windows 7. and when i open the heythere file in the addons folder the 2 documents that I made show up as text files which is different than the one i downloaded from your website titled the same (which also doesnt work). Im not sure what im doing wrong... I have not downloaded lua or anything yet but it doesnt say anything about that until 1.2 so I thought I would be safe. Ive looked for this topic in the forums but it would appear that I am only one having issue with this :(

    Also when I say the addon does not show up im talkin about in game when I am supposed to click which addons I want to enable before I "enter world" with my character

    Also I should add that I used windows notepad to write the 2 documents

    Ok so I have rechecked the heythere folder that I downloaded from your website and realized that when I extracted it into my addon folder its had the original? folder. SO basically I took the "heythere" folder that was inside and put it directly into my addon folder and got rid of the other one ( I guess the zip file)..anyway that worked, but I still havent got the one I wrote to work. but im guessing that has something to do with the different file types. like I said mine are text documents and the ones from the website are lua and toc file types... so yea perhaps you can see the extent to which I dont understand..because even knowing that I STILL dont know what to do.

    OK I DID IT! well I did 2 things and im not sure which one fixed it..perhaps both. SO 1st, when saving the file I clicked all file types so that it would save as a lua or toc file...which it did. so that fixed the file types because now it recognized them that way. Next I realized I saved the file in my addons folder as Hey There and not HeyThere. I then realized that was the only file in my addons folder where there was a space in between. after I combined the 2 ...it showed up ingame folder that I was able to enable... so yea basically Im trying to say that Im awesome. hooray for noobishness. look forward to more ridiculously simple questions.

    <3

    Hey dude, so I'm having this same problem, I'm on patch 5.0.5 and I can't get mine to show up in game at the addons. So maybe you can tell me what to do or something? That would me super nice.

    What are the file names and where did you place them? What did they oontain? You can use something like pastebin to post the contents.