1. Book says go to http://wowprogramming.com/downloads/lua/macosx

    The .dmg link replies with: Whoops, page utils/mac/lua-wow does not support action .dmg.

    help? I'd like to follow the book's utils as much as possible.

    Thanks!

    Seeing as how this is a mac app, may I suggest that you add version numbers in the Info window now? It's your call of course, only suggesting.

    So did you install it?

    At least I have been able to get the WowLua Interperter to work so far; however; I really liked the idea of a clickable Mac application though.

    Please download the new version. There may still be an issue with readline support, but if you at least get a reasonable error message then we've made progress: http://wowprogramming.com/utils/mac/lua-wow.dmg

    Well, seeing as how I went ahead and installed Lua 5.1.3, should I do this also? I just want to be careful. T~

    At least I have been able to get the WowLua Interperter to work so far; however; I really liked the idea of a clickable Mac application though.

    Please download the new version. There may still be an issue with readline support, but if you at least get a reasonable error message then we've made progress: http://wowprogramming.com/utils/mac/lua-wow.dmg

    At least I have been able to get the WowLua Interperter to work so far; however; I really liked the idea of a clickable Mac application though.

    Book says go to http://wowprogramming.com/downloads/lua/macosx

    The .dmg link replies with: Whoops, page utils/mac/lua-wow does not support action .dmg.

    help? I'd like to follow the book's utils as much as possible.

    Thanks!

    I've actually just uploaded the package, let me know if you have any issues with it.

    The weblua option does not appear to be working properly. For example- - > print("howdy") An unexpected error occured

    Seeing as how this is a mac app, may I suggest that you add version numbers in the Info window now? It's your call of course, only suggesting.

    T~

    At least I have been able to get the WowLua Interperter to work so far; however; I really liked the idea of a clickable Mac application though.

    Please download the new version. There may still be an issue with readline support, but if you at least get a reasonable error message then we've made progress: http://wowprogramming.com/utils/mac/lua-wow.dmg

    The weblua option does not appear to be working properly. For example- - > print("howdy") An unexpected error occured

    I've fixed this error, thanks for the report.

    For right now I'd suggest using the (WebLua option or the downloadable addon. Unfortunately there were some problems getting the package generated for machines that aren't running a recent version of Mac OS X.

    Alternatively, you can download Lua from http://luaforge.net/frs/download.php/3078/lua513Darwin811x86bin.tar.gz. The installation will be slightly different, but should give you a working installation. I'll post here once the package has been created.